Ticket #5 (closed enhancement: fixed)

Opened 10 years ago

Last modified 10 years ago

Wget version requirement

Reported by: charles@nepote.org Owned by: vdv@dyomedea.com
Priority: minor Milestone:
Component: wp-plugin Version:
Keywords: Cc:

Description

There is a test made for wget >= 1.12.

Wget 1.11.4 (featured in Debian Lenny which is not so old and still in use on many servers), doesn't have "--adjust-extension" used by Owark.

BUT :

  1. "--adjust-extension" is the new name of the "--html-extension" from 1.11.4
  2. Option "-E", both used by 1.12 et 1.11.4, is a shortcut to "--adjust-extension" and to "--html-extension".

So I would :
-- remove --adjust-extension, redondant with -E
-- test wget => 1.11.4 and not just 1.12

(Sorry I can't try for the moment as I have to upgrade our Wordpress first.)

Change History

comment:1 Changed 10 years ago by vdv@dyomedea.com

  • Status changed from new to accepted

Hi Charles,

Sounds good.

This option is really handy for whet we're trying to achieve (I have tried to use the plugin with wget 1.10 that doesn't have the option at all and came to the conclusion that the code would have been much more complex) but if it is already there in 1.11 that shouldn't be an issue and I'll update the code.

Thanks,

Eric

comment:2 Changed 10 years ago by vdv@dyomedea.com

  • Status changed from accepted to closed
  • Resolution set to fixed

I have tested the modification you're suggesting on the brand new blog that I have created for the project and it's working fine (see for instance the archive of the project home page: http://owark.org/blog/owark/9/ ).

The updates have been checked in as r158172880f573bbb2bb741935b1d5a6d94568216 .

Thanks,

Eric

Note: See TracTickets for help on using tickets.